Intrusion Prevention

Piwigo.Photo.Gallery.Project.LocalFiles.Editor.Plugin.XSS

Description

This indicates an attack attempt to exploit a Cross-Site Scripting vulnerability in Piwigo LocalFilesEditor.
The vulnerability is due to insufficient sanitizing of user supplied inputs in the application when handling crafted HTTP Post request. A remote attacker may be able to exploit this to execute arbitrary script code within the context of the application, via a crafted HTTP request.

Affected Products

Piwigo project Piwigo 2.4.6 and prior

Impact

System Compromise: Remote attackers can execute arbitrary script code in the context of the affected site.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://piwigo.org/bugs/view.php?id=0002844

CVE References

CVE-2013-1468