Intrusion Prevention

HybridAuth.Install.PHP.Code.Execution

Description

This indicates an attack attempt to exploit a Code Injection Vulnerability in HybridAuth.
The vulnerability is due to an input validation error while parsing a crafted HTTP request. A remote attacker could exploit this to execute arbitrary code within the context of target application, via crafted HTTP request.

Affected Products

HybridAuth versions 2.0.9 to 2.2.2

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Currently we are unaware of any vendor supplied patch for this issue.