Intrusion Prevention

Adobe.Shockwave.Player.DEMX.Atom.Handling.Memory.Corruption

Description

This indicates an attack attempt against a Memory Corruption vulnerability, which was discovered by Fortinet's FortiGuard Labs, in Adobe Shockwave Player.
This vulnerability is caused due to insufficient validation on the index value inside 'demx' atom. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application.

Affected Products

Adobe Shockwave Player 12.1.8.158 and earlier

Impact

System Compromise: Remote attackers could gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://helpx.adobe.com/security/products/shockwave/apsb15-17.html

CVE References

CVE-2015-5121