Intrusion Prevention

RedHat.JBoss.BPM.Suite.BRMS.Tasks.List.XSS

Description

This indicates an attack attempt to exploit a Cross-Site Scripting vulnerability in Red Hat JBoss BPM Suite and JBoss BRMS.
The vulnerability is due to insufficient sanitizing of user supplied inputs in the application when handling a crafted HTTP request. A remote attacker can exploit this to execute arbitrary script code within the context of the user's browser.

Affected Products

Red Hat JBoss BPMS prior to 6.4.3
Red Hat JBoss BRMS prior to 6.4.3

Impact

System Compromise: Remote attackers can execute arbitrary script code within the context of the target user's browser

Recommended Actions

Apply patch available from the website.
https://access.redhat.com/errata/RHSA-2017:1218

CVE References

CVE-2017-2674