Intrusion Prevention



This indicates an attack attempt to exploit a Code Execution vulnerability in Oracle WebLogic Server.
The vulnerability is due to insufficient sanitizing of user supplied inputs in the wls-wsat component, when handling a maliciously crafted HTTP request. A remote attacker may be able exploit this to execute arbitrary code within the context of the application via a crafted request.

Affected Products

Oracle Weblogic Server 10.3.6 0
Oracle Weblogic Server
Oracle Weblogic Server
Oracle Weblogic Server


System Compromise: Remote attackers can gain control of vulnerable systems

Recommended Actions

Apply the most recent upgrade or patch from the vendor.

CVE References

CVE-2017-10271 CVE-2017-3506