Intrusion Prevention

Apache.Tomcat.CGI.Servlet.Remote.Code.Excecution

Description

This indicates an attack attempt on a Remote Code Execution Vulnerability in Apache Tomcat for Windows.
This vulnerability is due to an error in the way command line arguments are passed when running on Windows with enableCmdLineArguments enabled. A remote attacker may be able to exploit this to execute arbitrary code, via a crafted request to a cgi script.

Affected Products

Apache Tomcat 9.0.0.M1 to 9.0.17
Apache Tomcat 8.5.0 to 8.5.39
Apache Tomcat 7.0.0 to 7.0.93

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://tomcat.apache.org/security.html

CVE References

CVE-2019-0232