Intrusion Prevention

YouPHPTube.Encoder.getImage.php.Command.Injection

Description

This indicates an attack attempt to exploit a Command Injection Vulnerability in YouPHPTube Encoder.
A remote, unauthenticated attacker could exploit this vulnerability by sending a crafted HTTP request to the vulnerable server. Successful exploitation could result in arbitrary system command execution under the context of the server process.

Affected Products

YouPHPTube Encoder 2.3 prior to commit 688b19445f28209ad727d0aeab5b47d819a6c7b4

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://github.com/YouPHPTube/YouPHPTube-Encoder/commit/688b19445f28209ad727d0aeab5b47d819a6c7b4

CVE References

CVE-2019-5127