Intrusion Prevention

Apache.Solr.Velocity.Template.Remote.Code.Execution

Description

This indicates an attack attempt to exploit an Remote Code Execution Vulnerability in Apache Software Foundation Solr.
A remote, unauthenticated attacker can exploit this vulnerability by sending crafted HTTP requests. Successful exploitation could result in arbitrary code execution in the context of the server application.

Affected Products

Apache Software Foundation Solr 7.7.2 to 8.3

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://lucene.apache.org/solr/news.html